Errors processing credit card payments
Incident Report for Penn State Better Kid Care
Resolved
Payment processing was interrupted temporarily by Converge maintenance: https://status.elavon.com/issues/6424ab314a0ebd7ab0066ccf
Posted Apr 04, 2023 - 12:33 EDT
Investigating
We are currently investigating this issue.
Posted Apr 04, 2023 - 11:39 EDT
This incident affected: Payment.