Slow performance for OnDemand
Incident Report for Penn State Better Kid Care
Resolved
This incident has been resolved.
Posted Feb 28, 2020 - 17:14 EST
Investigating
We are currently investigating this issue.
Posted Feb 28, 2020 - 13:53 EST
This incident affected: Courses, Payment, Email notifications, and Forums.