On Demand site unreachable due to expired SSL Certificate
Incident Report for Penn State Better Kid Care
Resolved
A new certificate has been installed. On Demand is fully operational once again. Additional monitoring has been added to detect expiring certificates well in advance.
Posted Jun 01, 2022 - 10:54 EDT
Update
We're waiting on a new SSL Certificate to be issued from Penn State support.
Posted Jun 01, 2022 - 10:17 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 01, 2022 - 10:09 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 01, 2022 - 09:41 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 01, 2022 - 09:40 EDT
Investigating
Users will notice a warning such as "Your connection is not private" when trying to reach Better Kid Care On Demand. This is due to an expired SSL Certificate. We are in the process of updating the certificate. We apologize for the inconvenience.
Posted Jun 01, 2022 - 09:39 EDT
This incident affected: Courses, Payment, and Forums.