Slow perfromance for OnDemand
Incident Report for Penn State Better Kid Care
Resolved
This incident has been resolved.
Posted Feb 26, 2020 - 16:32 EST
Identified
Intermittent degredations in performance are still being reported in Penn State's network. Some OnDemand users may experience slow responses from the site. We'll update as soon as Penn State's IT has resolved the issue.
Posted Feb 26, 2020 - 16:25 EST
Update
The problem appears to be with Penn State's network.
Posted Feb 26, 2020 - 14:55 EST
Update
We are continuing to investigate this issue.
Posted Feb 26, 2020 - 14:46 EST
Investigating
We are currently investigating this issue.
Posted Feb 26, 2020 - 14:46 EST
This incident affected: Courses, Payment, Email notifications, and Forums.