Btter Kid Care OnDemand system is not accessible
Incident Report for Penn State Better Kid Care
Resolved
This incident has been resolved.
Posted Jul 20, 2021 - 12:42 EDT
Update
We are continuing to investigate this issue.
Posted Jul 20, 2021 - 08:32 EDT
Investigating
The enterprise network at Penn State where Better Kid Care is hosted is currently down. We'll continue to monitor the situation and update status. For more information, here's a link to Penn State's network incident: https://pennstate.service-now.com/sp?id=service_status&service=d2aedfba0ff1b100f178317ce1050e30
Posted Jul 20, 2021 - 08:31 EDT
This incident affected: Courses, Payment, Email notifications, and Forums.