Images not displaying
Incident Report for Penn State Better Kid Care
Postmortem

Images stopped loading

Description of problem

Over the past couple of weeks an increasing number of OnDemand users have noticed images were no longer loading. This was due to the fact that browsers have started ensuring that https:// pages can only load secure https:// sub-resources. The OnDemand media server is not set up to handle https requests, so images are served via http. If a user’s browser enforced the http restriction, images would not load for them and this prevented them from navigating lessons and seeing all of the content.

Resolution

We are now serving all images through https using a Cloud Delivery Network (CDN).

Posted Oct 01, 2020 - 10:00 EDT

Resolved
This incident has been resolved.
Posted Oct 01, 2020 - 09:36 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 30, 2020 - 23:48 EDT
Identified
Newer versions of Chrome and Internet Explorer are preventing images from being displayed. Users are still able to navigate and complete lessons. We've identified the cause of the issue and we're working on implementing a solution. In the meantime, if your browser is not loading images, please try using the Firefox web browser.
Posted Sep 30, 2020 - 15:37 EDT
This incident affected: Courses.