Major outage
Incident Report for Penn State Better Kid Care
Resolved
This incident has been resolved.
Posted Mar 17, 2021 - 15:04 EDT
Monitoring
All systems have been available for several minutes, and PSU's systems have stabilized as well. We'll continue to monitor.
Posted Mar 17, 2021 - 12:47 EDT
Update
This outage is part of a broader Penn State University-wide outage. We're continuing to monitor the situation.
Posted Mar 17, 2021 - 11:56 EDT
Update
We are continuing to investigate this issue.
Posted Mar 17, 2021 - 11:55 EDT
Investigating
We are currently investigating this issue.
Posted Mar 17, 2021 - 11:42 EDT
This incident affected: Courses, Payment, Email notifications, and Forums.