Payment gateway is down
Incident Report for Penn State Better Kid Care
Resolved
The payment gateway has been stable for almost an hour. We're marking this issue as resolved.
Posted Dec 28, 2020 - 20:54 EST
Monitoring
The payment gateway provider's services seem to have recovered. On Demand should now be able to process payments again. We will continue to monitor the service to ensure that it remains stable.
Posted Dec 28, 2020 - 20:07 EST
Identified
The payment solution that Better Kid Care uses for processing credit card payments is experiencing an outage. We verified that the issue is on their end, and we are seeing signs that the service is starting to recover. In the meantime, Better Kid Care is not able to process any credit card payments. We will continue to investigate and monitor the situation.
Posted Dec 28, 2020 - 18:25 EST
This incident affected: Payment.