Intermittent outages
Incident Report for Penn State Better Kid Care
Resolved
This incident has been resolved.
Posted Mar 17, 2021 - 23:06 EDT
Identified
There are intermittent network outages throughout Penn State, and these are impacting availability of the Better Kid Care On Demand system. Users may experience slow page loads, availability issues, or see no impact at all. We'll provide periodic updates as they become available.
Posted Mar 17, 2021 - 17:20 EDT
This incident affected: Courses, Payment, Email notifications, and Forums.