Degraded payment processing performance for AT&T smartphone users
Incident Report for Penn State Better Kid Care
Resolved
This incident has been resolved.
Posted Apr 25, 2024 - 09:37 EDT
Monitoring
We received notice of an issue from our credit card payment processor potentially affecting the quality of mobile service, specifically for certain customers using AT&T smartphones. If you are using an AT&T smartphone and are experiencing connection problems, you are advised to use your internet connection or Wi-Fi if available until the mobile service issue is resolved.
Posted Mar 25, 2024 - 10:28 EDT
This incident affected: Payment.