Payment Gateway Down
Incident Report for Penn State Better Kid Care
Resolved
This incident has been resolved.
Posted Jul 03, 2019 - 13:30 EDT
Update
We are continuing to monitor for any further issues.
Posted Jul 03, 2019 - 11:58 EDT
Monitoring
Converge's API is currently down.
Posted Jul 03, 2019 - 11:58 EDT
This incident affected: Payment.